NEU: Mengeneingabe als PullDown (awidsQtyPullDown) für modified-2.x-Shops

NEU: Mengeneingabe als PullDown (awidsQtyPullDown) für modified-2.x-Shops
Für eine größere Ansicht klicken Sie auf das Vorschaubild
Lieferzeit: Sofortdownload
Art.Nr.: KE0005
Hersteller: AWIDS
Mehr Artikel von: AWIDS
ab 20,00 EUR
zzgl. 19 % MwSt.
Download
Leistungen



  • Details
  • Eigenschaften
  • Mehr Bilder

Produktbeschreibung

Im modified-Support-Forum würden einige User jetzt wohl anmerken, dass man dieses PullDown auch durch eine einfache Anlage einer Datei, welche man durch ein Auto-Include im entsprechenden Ordner ablegt, erzeugen könnte. Dies stimmt, aber ich habe mich dagegen entschieden.

Warum? Ganz einfach:
Als Anwender hat man unterschiedliche Bedürfnisse an so ein PullDown.

Während Anwender A z. B. nur eine Auswahl in Höhe des tatsächlichen Artikelbestandes zulassen möchte, will Anwender B dann vielleicht aber lieber mit einer Begrenzung arbeiten, sodass ihm dort nicht 999+ Auswahlmöglichkeiten gegeben werden, sondern nur 20, 50 oder 100. Und dann kommt Anwender C und wünscht sich eine Kombination aus beidem, nämlich eine feste Obergrenze von beispielsweise 20 Auswahlmöglichkeiten, welche aber den Lagerbestand des Artikels berücksichtigt und bei 5 vorrätigen Artikeln auch nur 5 Auswahlmöglichkeiten bietet.

Diese Möglichkeiten werden über mein Modul abgedeckt. Natürlich kann man sich seine Wunschlösung auch in einer einfachen Auto-Include-Datei zusammenstricken, aber dies bedeutet einen händischen Eingriff in eine Datei, was zumindest Grundkenntnisse in der Programmierung voraussetzt. Nicht jeder Shopbetreiber bringt diese automatisch mit, sondern orientiert sich anhand von Anleitungen aus dem Support-Forum, ohne wirklich zu wissen, was er dort macht. Die gut erklärten Schalter in der Modul-Konfiguration machen einen Datei-Eingriff unnötig und man ist flexibler, wenn sich die Bedürfnisse ändern, da man nicht jedes Mal die Datei aufs Neue bearbeiten muss. Die Vorteile liegen also klar auf der Hand.

 

Produkteigenschaften

Kompatible Shopversionen: 2.0.0.0 , 2.0.1.0 , 2.0.2.0 , 2.0.2.1 , 2.0.2.2 , 2.0.3.0
PHP-Kompatibilität: PHP 5.6 , PHP 7.0 , PHP 7.1 , PHP 7.2
Coreanpassungen: Nein
Templateanpassungen: Ja
Updatesicher: Ja
Übersicht   |   Artikel 1 von 5 in dieser Kategorie « Erster   |   « vorheriger   |   nächster »   |   Letzter »